OSPF の概要
Created by: 2005-11-23 non sugar
Modified by: 2008-01-05 non sugar

目次

設定

認証

router ospf 1
 router-id 1.1.1.1
 area 0 authentication message-digest
interface Vlan20
 ip ospf message-digest-key 1 md5 hoge

デフォルトルートのアダバタイズ

PC でのパケットキャプチャ

# tcpdump -i eth0 ip[9] == 89

OSPF のフィルタリング

  • IOS は、3つの主要な OSPF フィルタリングをサポートしている。
    • ルートをフィルタする。LSA はフィルタしない。 distribute-list in コマンドを使い、SPF の処理でルーティングテーブルにルートを追加しようとする時に、フィルタを適用できる。LSDB には影響しない。
    • ABR type 3 LSA フィルタリング。type 3 summary LSA を ABR でフィルタする。
    • area range no-advertise option。 type 3 summary LSA を ABR でフィルタする。

distribute-list によるルートフィルタ

  • OSPF における distribute-list は、IP ルーティングテーブルにフィルタをするが、distribute-list を設定したルータにだけ有効である。
  • inbound は、LSA のインバウンドをフィルタしない。代わりに、SPF がルーティングテーブルにルートを注入するルートをフィルタする。

(例) rid=2.2.2.2 からのルート 10.5.5.0/24 をフィルタ

+-----------+s0.1   +-----------+
|           +-------+rid=1.1.1.1|
|           |       +-----------+
|           |
|rid=3.3.3.3|s0.2   +-----------+
|           +-------+rid=2.2.2.2|
|           |       +-----------+
+-----------+
                           
! Example1
ip prefix-list prefix-10-5-5-0 seq 5 deny 10.5.5.0/24
ip prefix-list prefix-10-5-5-0 sqe 10 permit 0.0.0.0/0 le 32
!
router ospf 1
 distribute-list prefix prefix-10-5-5-5 in s0.2
!
! Example2
router ospf 1
 distibute-list route-map map-10-5-5-5 in
!
access-list 30 permit 10-5-5-0
access-list 31 permit 2.2.2.2
!
router-map map-10-5-5-5 deny 10
 match ip address 30
 match ip route-source 31
router-map map-10-5-5-5 permit 20
!

外部ルート E1, E2

  • 選択される外部ルートは、
    • 送信先が同じ場合、E1 が E2 よりも、常に優先
    • 外部ルートが両方とも E2 で送信先ネットワークへの外部コストが等しい場合、ASBR へのコストが最も低いパス

参考

Cisco Web サイト

RFCs


Last-modified: 2012-10-24 (水) 10:41:24 (678d)